Error When Upgrading WSUS 3 SP2

While trying upgrade Windows Server Update Services, WSUS, I experience the following error in the setup log and the install would stop:

2010-01-08 10:37:52  Error     MWUSSetup          ExecuteQuery: Failed to execute SQL query USE SUSDB IF EXISTS (select * FROM master..sysdatabases WHERE name= N’SUSDB’ AND suser_sname(sid) is null) EXEC dbo.sp_changedbowner N'”DomainName”\administrator’ (Error 0x80040E14)
2010-01-08 10:37:52  Error     MWUSSetup          ExecuteQueryGetNoResults: Failed to execute query USE %s IF EXISTS (select * FROM master..sysdatabases WHERE name= N’%s’ AND suser_sname(sid) is null) EXEC dbo.sp_changedbowner N’%s’ (Error 0x80040E14)
2010-01-08 10:37:52  Error     MWUSSetup          CUpgradeDriver::PerformPreSetupActions: Failed to reset database owner name for SUSDB to owner DomainName\administrator (Error 0x80040E14)
2010-01-08 10:37:52  Error     MWUSSetup          CSetupDriver::LaunchSetup: Failed to perform pre-setup actions (Error 0x80040E14)
2010-01-08 10:37:52  Error     MWUSSetup          CProgressManager::EnableCancel: GetDlgItem returning error (Error 0x80070578: Invalid window handle.)
2010-01-08 10:38:03  Error     MWUSSetup          CWatsonHelper::Init: Failed to load WER library. (Error 0x8007007E: The specified module could not be found.)
2010-01-08 10:38:03  Error     MWUSSetup          CSetupDriver::ReportFailure: Failed to initalize the CWatsonHelper.  This is expected on pre-Vista machines. (Error 0x80004005: Unspecified error)
2010-01-08 10:38:03  Error     MWUSSetup          DoInstall: Wsus setup failed (Error 0x80040E14)
2010-01-08 10:41:37  Success   MWUSSetup          Validating pre-requisites…

To resolve the issue I downloaded Windows Installer CleanUp Utility, installed it and ran the utility.  Using the Utility I removed Windows Update Services.

After removing Windows Update Services I was able to successfully install WSUS sp2 with one minor issue.  The first time I ran the install I recieved the following message in the setup log:

CInstallDriver::PerformSetup: WSUS installation failed (Error 0x80070643: Fatal error during installation.)

I ran WSUS30-KB972455-x86.exe a second time and everything installed properly.

Leave a Reply

Your email address will not be published. Required fields are marked *

*

Subscribe without commenting